Customer Dashboard maintenance - investigating backend issue
Scheduled for 29 May, 2025 at 8:05 PM – 9:05 PM
Affects
Website
Under maintenance from 8:05 PM to 9:05 PM
Dashboard
Under maintenance from 8:05 PM to 9:05 PM
Completed
29 May, 2025 at 9:05 PMCompleted
29 May, 2025 at 9:05 PMMaintenance has completed successfully
In progress
29 May, 2025 at 8:05 PMIn progress
29 May, 2025 at 8:05 PMMaintenance is now in progress
Planned
29 May, 2025 at 8:05 PMPlanned
29 May, 2025 at 8:05 PMWe are performing an urgent maintenance to investigate an issue with the backend of the system, causing some small issues which need to be fixed.